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About this tutorial 
In this tutorial, you will adjust the network for a project that contains GNSS, total station, 
and level data. 

Notes: 

 To perform a network adjustment on combined GNSS, total station, and level data as 
described in this tutorial, you must be running Spectra Precision Survey Office 
software with the Complete product license. To verify the product license for your 
installation, select Help > Spectra Precision Survey Office and click the License 
button. Licensed features are displayed in the Features list. 

 If you need additional help at any time you are using the software, press F1 to display 
the online help. 

 

Step 1. Open the project 
For this tutorial, you will use the project file Adjusting the Network.vce. GNSS, total 
station, and level data has already been imported into the project, and GNSS baselines 
have been processed. 

1. On the Spectra Precision Survey Office menu bar, select File > Open Project. Or, 
click the Open Project icon  on the toolbar. 

2. In the Open File dialog, browse to C:\Spectra Precision 
Tutorials\SPSO\Projects\Adjusting the Network.vce and click Open. 

If you installed the tutorial to a location other than the default location shown here, 
browse to that location. 
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The project opens in the Spectra Precision Survey Office window. 

 

Note: This figure shows the Plan View tab with a white background. Your 
background may be black. If you want to change it to white, select Tools > Options 
and select Background color: White in the Options dialog. 

The project file is read-only. You can perform the tutorial steps without saving the project 
file. However, if you are interrupted while performing the tutorial, you can save it by 
selecting File > Save Project As and saving it to ..\My Documents\Spectra Precision 
Survey Office, which is the typical location for storing project files on your computer. 
Then, you can re-open the project to continue the tutorial at a later time. 

Before you adjust the network in your project, you must make a few changes to your 
project settings. 

Step 2. Modify project settings 
In this step, you will select the sources to use for default standard errors. Then, you will 
specify default standard errors for total station, leveling, and GNSS data. 

1. Select Project > Project Settings. Or, click the Project Settings icon  on the 
toolbar. 
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2. In the navigation (left) pane in the Project Settings dialog, select Network 
Adjustment > General. Then select Use Mean Angle Results in the Mean angles 
drop-down list. 

 

3. In the navigation pane, select Default Standard Errors. Then select options as 
follows: 

 Total Station: 
- Source for standard errors: Imported Files 
- Source for centering errors: Project Settings 

 Leveling: 
- Source for standard errors: Project Settings 

 GNSS: 
- Source for standard errors: Baseline Processor 

 Azimuth: 
- Source for standard errors: Project Settings 

4. In the navigation pane, select Default Standard Errors > Total Station. Then select 
options as follows: 

 Default Standard Errors: 
- Horizontal angle: 0°00'05" 
- Vertical angle: 0°00'05" 

 Default Centering Errors: 
- Instrument centering error: 0.002 m 
- Target centering error: 0.002 m 

 Default Height Errors: 
- Error in height of instrument: 0.002 m 
- Error in height of target: 0.002 m 

5. In the navigation pane, select Default Standard Errors > Leveling. Then select 
options as follows: 

 Default Standard Errors: 
- Default standard error on 1 km of double leveling: 0.0 mm 
- Default standard error for each station setup: 3.0 mm 

6. In the navigation pane, select Default Standard Errors > GNSS. Then select options 
as follows: 

 Default SetupErrors: 
- Error in height of antenna: .002 
- Centering error: .005 
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7. Click OK to close the Project Settings dialog. 

You are now ready to perform a network adjustment. You will do this using a two-step 
process. First, you will perform a minimally constrained network adjustment. Then, you 
will perform a constrained network adjustment. 

Step 3. Perform a minimally constrained network 
adjustment 

To evaluate the internal consistency of the survey network, you must first perform a 
minimally constrained network adjustment, which uses the minimum number of 
constraints required to define the coordinate system. 

1. Select Survey > Adjust Network. 

The Adjust Network pane displays. 

 

There are 13 control points listed on the Fixed Coordinates tab. Ten are the vertical 
control points from the DiNi level data and the data sheet: 

 B412 

 barbara 

 ENERGY 

 F 408 

 flange 

 hard 

 Jeffco AZ MK 

 Jeffco Reset 

 Jeffco Reset 

 sixtwo 

Three are horizontal control points from the CORS (Continuously Operating 
Reference Stations) data sheet: 

 P041 

 PLTC 
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 TMGO 

For this project, you will perform a minimally constrained adjustment by holding the 
station P041 fixed in 2D and h. 

2. On the Fixed Coordinates tab, select the 2D and h checkboxes for P041. 

 

3. Click the Adjust button. 

A message displays asking if you want to resolve project computation errors. Click 
the Yes button to continue the network adjustment without resolving the errors. 

A summary of the results of the adjustment displays on the Results tab in the Adjust 
Network pane. 

 

The Reference factor is 1.35, the Degrees of freedom is 268, and the Chi Square 
test has Failed. This indicates that some vectors may have been flagged as outliers 
in the adjustment and/or it is necessary to apply a weighting strategy to the 
processed vectors. 

4. In the Adjust Network pane, click the Report icon . 

The Network Adjustment Report displays in your browser window. To navigate to the 
various sections of the report, click the links in the navigation pane on the left side of 
the report, or use your mouse to scroll through the report. 

5. Review the report, paying particular attention to the "Observations" sections. 
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Observations with a standardized residual that fails the Tau criteria are displayed in 
red. These observations are outliers. In this case, the post-processed vectors TMGO 
--> PLTC (PV135) and filter --> 5 (PV22) are flagged as outlier (red text) in the 
"Adjusted GPS Observations" section.  

 

Note: The software automatically assigns a number in parenthesis to each set of 
observations. The numbers in your report may vary from the numbers shown above. 

Since you have a high-level redundancy in the network, you can disable TMGO --> 
PLTC (PV135) and filter --> 5 (PV22), then readjust the network. 

6. In the Network Adjustment Report, click the TMGO --> PLTC (PV135) link in the 
"Adjusted GPS Observations" section. 

This selects the vector in the project. 

7. In the Spectra Precision Survey Office window, right-click on the Plan View and 
select Properties in the context menu. 

The Properties pane displays showing TMGO --> PLTC (PV135). 

 

Note: If you click anywhere else in the window before right-clicking on the Plan View, 
the vector will no longer be selected. 

8. In the Status drop-down list, select Disabled. 
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The Clear Adjustment message dialog displays asking whether you want to keep or 
clear the results of the previously performed network adjustment.  

9. In the Clear Adjustment dialog, click the Clear Adjustment button. 

10. Repeat steps 6 through 8 for vector filter --> 5 (PV22)  

With TMGO --> PLTC (PV135) and filter --> 5 (PV22) disabled, you can now repeat 
the network adjustment process. 

11. Select Survey > Adjust Network. Then click the Adjust button to repeat the 
minimally constrained network adjustment. 

A message displays asking if you want to resolve project computation errors. Click 
the Yes button to continue the network adjustment without resolving the errors. 

A summary of the results of the adjustment displays on the Results tab in the Adjust 
Network pane. 

 

12. Click the Report icon  to view the Network Adjustment Report. 

The Chi Square test has still failed, so it is necessary to apply a weighting strategy to 
the processed vectors. Applying a weighting strategy will improve the initial a priori 
error estimates for the observations. A priori errors are estimated errors for 
observations before a network adjustment is performed. 

13. In the Adjust Network pane, select the Weighting tab. 

 

In the Postprocessed vectors section, the network reference factor is listed in the 
box on the left as 1.04. The goal is to get the reference factor to 1.0. 

14. In the Postprocessed vectors, Horizontal angles, Vertical angles, Slope 

distances, and Leveling sections, click  to apply a scalar to the estimated errors. 
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The software computes a new scalar using the network reference factor from the last 
adjustment. This scalar is applied to the initial error estimates for all postprocessed 
vectors in the adjustment. 

You are now ready to re-compute the minimally constrained adjustment. 

15. Click the Adjust button 

A message displays asking if you want to resolve project computation errors. Click 
the Yes button to continue the network adjustment without resolving the errors. 

The Results tab displays in the Adjust Network pane. 

 

The network Reference factor is now .96 and the Chi Square test has Passed. The 
initial a priori error estimates agree with the adjusted errors for the network vectors.  

You are now ready to perform a constrained network adjustment. 

Step 4. Perform a constrained network adjustment 
In this step, you will perform a constrained adjustment in which the remaining control 
points are held (fixed) to the coordinates from the imported data sheets. The object is to 
compute adjusted coordinates for the measured points in the survey network, relative to 
the existing control stations. 

The stations in this survey are of mixed survey quality, including: 

 CORS (Continuously Operating Reference Stations) quality 

 Varying qualities from national network reference stations 

 Adjusted DINI observation quality  

You can assign standard error values to each control point based on its quality, using 
previously adjusted values from past surveys or error estimates from CORS or national 
network reference station adjustments. When you assign a standard error to a control 
point, you enable the network adjustment to adjust the coordinate value of the control 
point based on the quality of the observations and the other control points. 

If you choose not to assign standard error values, a “fixed” value of 0.000001m 
(micrometer) is assigned to each point regardless of point quality. 

For this tutorial, you will enter “fixed” values for the CORS stations, accuracy estimates 
from the National Geodetic Survey (NGS) datasheets, along with some assumed values 
for the lower order control points. 
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1. In the Adjust Network pane, select the Fixed Coordinates tab. Then click the Use 
assigned weighting icon  at the top of the pane. 

The Fixed Coordinates tab is replaced by the Constrained Coordinates tab. 

 

You can now expand each control point to enter standard error estimates. For this 
tutorial, you will enter the North and East values of the estimates. (If available, you 
can enter the horizontal values.) However, before doing so, you will need to make 
some changes to your project settings. 

2. Select Project > Project Settings and do the following:  

a. Select Units > Coordinate and select Yes in the Expand horizontal standard 
errors drop-down list. 

 

b. Select Units > Distance and select 0.1234 in the Decimal precision drop-down 
list. 

c. Click OK to close the Project Settings dialog. 

3. On the Constrained Coordinates tab in the Adjust Network pane, do the following: 

a. Click the plus symbol to expand B412. Then enter 0.0100 m in the Elevation 
field. 
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b. Click the plus symbol to expand barbara and enter: 
0.0074 m in the North field 
0.0057 m in the East field 
0.0294 m in the Height field 

 

Typically , you would enter error estimates for the rest of the points as well. However, 
for this tutorial the additional values have already been entered. 

Error estimates entered for a point are used in the adjustment only if you select one 
or more of the "fix" checkboxes for the point, making it a constraint point. 

Although, in practice, you would generally take a more incremental approach to the 
constrained adjustment and add only one control point at a time, for this tutorial you 
will complete the constrained adjustment in two steps. First, you will constrain the 
NAD83 local geodetic coordinates for the three horizontal control points. Then, you 
will add the elevation constraints for the Trimble DiNi control elevation. 

Note the following: 

 Local (2D and h) values refer to NAD83 local geodetic (latitude, longitude, and 
ellipsoid height) coordinates imported from the data sheets. 

 Grid (e) values refer to NAVD88 elevations imported from the data sheet or the 
adjusted digital level files. 

For this tutorial, you will constrain points using the local geodetic coordinates. You 
will add elevation constraints later. 

4. Collapse the expanded point nodes and select the constraints for the adjustment by 
selecting the 2d and h checkboxes for the following points: 

 hard 

 P041 (should already be checked) 

 PLTC  

 TMGO 
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5. Click the Adjust button. 

A message displays asking if you want to resolve project computation errors. Click 
the Yes button to continue the network adjustment without resolving the errors. 

The Results tab displays. 

 

Typically, you would now review the Network Adjustment Report. Based on that 
review, you might decide to select some other horizontal control points. For this 
tutorial, you will proceed without selecting other horizontal control points. 

Next, you will constrain only the 2D coordinates for the three horizontal control points. 
You will also add the benchmark elevations as vertical constraints. In this way, the 
network is constrained horizontally to the NAD83 local geodetic coordinates and 
vertically to the NAVD88 benchmark elevations as measured by the DiNi level. 

6. On the Constrained Coordinates tab, deselect the h checkbox for each of the four 
local points: 

 hard 

 P041 

 PLTC 

 TMGO 

This removes the ellipsoid height constraints that you added earlier. 

7. Select the e checkbox for the grid points: 

 B 412 

 F 408 

 sixtwo 

This adds the benchmark elevation for the adjustment. 

8. Click the Adjust button. 

A message displays asking if you want to resolve project computation errors. Click 
the Yes button to continue the network adjustment without resolving the errors. 
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The Results tab displays. 

 

9. In the Spectra Precision Survey Office window toolbar, click the Zoom In icon  
as necessary to enlarge the view as shown here. Or, click on the Plan View and use 
your mouse wheel to zoom in. Press the mouse wheel and move the mouse to center 
the points. 

 

The error ellipses are displayed in red. 

10. In the Adjust Network pane, click the Report icon  and view the "Adjusted Grid 
Coordinates" section. 

This section of the report illustrates which coordinates were held fixed in the 
adjustment. All coordinates except for control points have estimated errors. 
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The Results tab in the Adjust Network pane displays errors and residuals for one or 
more selected points, observations, or postprocessed vectors. In the Plan View, 
select the items you want to view by drawing a box around them. Your selections 
display in the Results tab. 

 

You are done adjusting the network. Next, you will import additional data into your 
adjusted project. 

Step 5. Import additional data into the adjusted project 
If the additional job data you are importing includes the same point IDs as your adjusted 
project, you can select to have the new coordinates based on the adjusted coordinate 
values. In this case, you will import a new data file that includes a traverse from point 5 to 
point frey, points that already exist in your adjusted project. 

1. Select File > Import. Or, click the Import icon  on the toolbar. 

The Import pane opens in the right side of the Spectra Precision Survey Office 
window. 

 

2. In the Import pane, click the Browse button . 
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3. In the Browse for Folder dialog, browse to C:\Spectra Precision 
Tutorials\SPSO\Data\Adjusting the Network and click OK. 

4. In the Select File(s) list, select 53frey.jxl and click the Import button. 

Since the software detects a difference between the coordinate system specified in 
the project and the coordinate system specified in the imported file, the Project 
Coordinate System message dialog displays. 

5. Select the Keep the existing project definition option in the Project Coordinate 
System message dialog. Then click OK. 

The Clear Adjustment message dialog displays asking whether or not to keep the 
network adjustment you just completed. For this tutorial, you will keep the adjustment 
after importing the new data. 

6. In the Clear Adjustment dialog, click the Keep Adjustment button. 

The new data is imported based on the coordinate values of points 5 and frey that 
were calculated in the network adjustment. 

In the Spectra Precision Survey Office window toolbar, you can click the Zoom In 
icon (or use the mouse wheel) as necessary to enlarge the view as show here to see 
the newly imported traverse. 

 

7. Select View > Project Explorer. Then, in the Project Explorer pane, right-click 
Points > frey and select Point Derivation Report. 

The Point Derivation Report displays in a browser window. 

The report shows the value where point frey was established. In this case, it is the 
network adjusted value. You can also see the coordinate value from the 53frey.jxl file 
import. 

You are done adjusting the network. 

8. In the Spectra Precision Survey Office window, select File > Close Project. 

The Save Changes dialog displays. If you saved the project to a new location or with 
a new name, you can click Yes. Otherwise, click No. 
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