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About this tutorial 
In this tutorial, you will do the following: 

 Import grid coordinates for a survey of two water towers.  

 Import RTK data to use for the site calibration.  

 Specify how sideshots in the project are computed. 

 Pair up the local control points and GNSS control points, and perform the site 
calibration.  

 Save the calibrated site so you can reuse it for future projects in the same area. 

Note: If you need additional help at any time you are using the software, press F1 to 
display the online help. 

Understanding site calibration 
The site calibration process establishes the relationship between WGS-84 data collected 
by GNSS receivers and local control positions (expressed as a local map grid with 
elevations above sea level). This relationship is defined by a series of mathematical 
transformations. To calibrate a site, you must pair up GNSS and local control points to be 
used in the calibration.  

 Grid points must be derived from grid points and terrestrial observations.  

 GNSS coordinates must be derived from GNSS points and observations.  

The software then computes and applies the mathematical transformations using least 
squares. 

The mathematical transformations that are applied in order to convert WGS-84 positions 
to grid coordinates are as follows: 

 A datum transformation to convert the WGS-84 latitude, longitude, and ellipsoidal 
height coordinates to latitude, longitude, and ellipsoidal height coordinates relative to 
the ellipsoid of the local map grid 

 A map projection to convert the local ellipsoid latitude and longitude coordinates into 
local map grid northing and easting coordinates (the height value is not altered in this 
process) 

 A geoid model to WGS-84 height to get approximate elevation above sea level 

 A horizontal adjustment of the transformed grid coordinates to best-fit local control 
data (This adjustment allows for any local variations in the projection system that 
cannot be accommodated in the overall datum transformation.) 

 A height adjustment to convert the heights above the local ellipsoid or elevations 
derived from the geoid to local control elevations above sea level 

The horizontal and vertical adjustment are stored as part of the coordinate system 
definition for the project. All GNSS points in the database are updated using the 
calibration parameters, resulting in more accurate local grid coordinate values.  
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You can save the new coordinate system definition (which includes the calibration 
parameters) as a site for use in future projects in the same area. 

Step 1. Open the project 
For this tutorial, you will use the project file Calibrating a Site.vce.  

1. On the Spectra Precision Survey Office menu bar, select File > Open Project. Or, 
click the Open Project icon  on the toolbar. 

2. In the Open File dialog, browse to C:\Spectra Precision 
Tutorials\SPSO\Projects\Calibrating a Site.vce and click Open. 

If you installed the tutorial to a location other than the default location shown here, 
browse to that location. 

The project opens in the Spectra Precision Survey Office window. 

 

Note: This figure shows the Plan View tab with a white background. Your 
background may be black. If you want to change it to white, select Tools > Options 
and select Background color: White in the Options dialog. 

The project file is read-only. You can perform the tutorial steps without saving the project 
file. However, if you are interrupted while performing the tutorial, you can save it by 
selecting File > Save Project As and saving it to ..\My Documents\Spectra Precision 
Survey Office, which is the typical location for storing project files on your computer. 
Then, you can re-open the project to continue the tutorial at a later time. 

You are now ready to import data into your project. 

Step 2. Import data 
For this tutorial, you will import two data files: 

 2tank.jxl - This file contains the local grid coordinates. 

 2tankrtk.jxl - This file contains the GNSS coordinates. 

1. Select File > Import. Or, click the Import icon  on the toolbar. 
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The Import pane opens in the right side of the Spectra Precision Survey Office 
window. 

 

2. In the Import pane, de-select the Close command after import checkbox located 
near the bottom of the pane. 

This will cause the Import pane to stay open after the first import so you can perform 
a second import. 

3. In the Import pane, click the Browse button . 

4. In the Browse For Folder dialog, browse to C:\Spectra Precision 
Tutorials\SPSO\Data\Calibrating a Site and click OK. 

The content of the Calibrating a Site folder displays in the Select File(s) list in the 
Import pane. You will first import the data file containing the local grid coordinates. 

5. In the Select File(s) list, select 2tank.jxl and click the Import button. 

The Project Definition dialog displays, allowing you to change the scale factor for 
the imported file. 

6. In the Project Definition dialog, do not make any changes and click OK. 
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The coordinate data is displayed in the Plan View. 

 

Next, you will import the GNSS coordinates to be used for the site calibration. 

7. In the Import pane, select 2tankrtk.jxl in the Select File(s) list and click the Import 
button. 

The Import Feature Definitions dialog displays alerting you that any feature 
processing will be undone. 

8. In the Import Feature Definitions dialog, click Yes. 
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The content of the Calibrating a Site folder displays in the Select File(s) list in the 
Import pane. Note that the GNSS coordinates are in a different location than the 
local grid coordinates. 

 

9. In the Import pane, click the Close button. 

10. To better view both sets of coordinates, do the following: 

a. Select View > New Plan View. 

b. The Plan View2 tab displays. 

c. Right-click on the Plan View2 tab label and select New Vertical Tab Group in 
the context menu. 
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d. Use your mouse wheel as necessary to zoom in on each tab to better view the 
data (as shown here). 

 

Next, you will specify how sideshot computations are performed in your project. 

Step 3. Specify how sideshot points are computed 
Spectra Precision Survey Office allows you to specify how to compute the position for 
each sideshot point in your project: 

 Use a single observation. 

 Use the weighted mean of all observations. 

 Use the weighted mean of like observations (for example, all RTK observations or all 
total station observations). 

If you select to use a weighted mean, each observation is weighted based on its 
precision. 

For this tutorial you will choose to use the weighted mean of like observations. 

1. Select Project > Project Settings. Or, click the Project Settings icon  on the 
toolbar. 

2. In the navigation (left) pane in the Project Settings dialog, select Computations. 
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3. In the Sideshot computations drop-down list, select Weighted Mean of Like 
Observations. 

 

4. Click OK. 

You are now ready to calibrate the site. 

Step 4. Calibrate the site 
While performing the site calibration, you should be able to identify any major blunders. In 
addition, considering the size of the site, you should ensure all point residuals are less 
than 0.020 m. 

1. Select Survey > Site Calibration to display the Site Calibration pane. Or, click the 
 icon on the toolbar,  
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2. Select the Point List tab. 

 

This tab allows you to match the GNSS and grid point pairs to be used in the site 
calibration. For this tutorial, you will match the following pairs: 

 99_gps - 99 

 100el_gps - 100el 

 101_gps - 101 

 103_gps - 103 

 115_gps - 115 

 116_gps - 116 

Note: The coordinates of each point you select must be computed from global 
coordinates. Points with local coordinates cannot be selected as GNSS points. 

3. Enter the point pairs as follows: 

a. Click in the field to the right of the GNSS Point label and enter 99_gps. 

b. Click in the field to the right of the Grid Point label and enter 99. 

c. Press the Tab key to display fields to enter the next point pair. 

d. Repeat steps a through c for each of the point pairs listed in the previous step. 

As an alternative, you can choose the point to enter in any field by selecting it in the 
Plan View. 

4. Click the Compute button. 

Note: You may need to scroll down in the Site Calibration pane to see the Compute 
button. 

A warning message is displayed indicating that one or more points has a calibration 
computation that exceeds the maximum allowed residual of 0.100 m. This usually 
indicates some sort of blunder occurred either in the office or when selecting point 
pairs. 

5. Click OK in the Warning dialog. 
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The Results tab displays in the Site Calibration pane. 

 

6. Review the Results tab to identify which point pair is exceeding the maximum 
residual of 0.100 m. 

You can see that point 101_gps and point 116_gps both exceeded the maximum 
residual of 0.100 m.  

 

Because an error in a single point can propagate throughout the network causing 
other points to have large residuals even if they are correct, either of these points 
could be in error. So both points should be checked individually by changing the 
calibration to use the horizontal plane only and ignore the vertical plane, since this is 
the cause of the large residual. 

Normally, to resolve this problem you would start by checking for errors in the 
observation properties for each of these points (for example, instrument, target, and 
antenna information). You would also want to verify that the correct points were 
entered for these two point pairs. However, for this tutorial, you do not need to check 
for these types of blunders. 

7. In the Site Calibration pane, select the Point List tab and change the calibration 
type for point 116_gps from Horizontal and vertical to Horizontal only. Then click 
the Compute button. 

This time, no warning message is displayed. 

8. Review the Results tab. 

Although no points have a calibration computation that exceeds the maximum 
allowed residual of 0.100 m, note that points 103_gps and 115_gps have vertical 
residuals of -0.036 m and 0.027 m respectively. These residuals exceed the limit of 
0.020 m you specified as an objective for this site calibration. So you will reset the 
calibration type for point 116_gps and change point 101_gps to horizontal only. 
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9. In the Point List tab, reset the calibration type for point 116_gps to Horizontal and 
vertical and change point 101_gps to Horizontal only. Then click the Compute 
button. 

10. Review the Results tab. 

No residuals exceed the limit of 0.020 m.  

Note: If any horizontal residuals had exceeded 0.020 m, you would follow this same 
procedure. 

11. Click the Apply button to apply the calibration to the project. 

12. Click the Show Report button  located at the top of the Site Calibration pane to 
view the Site Calibration Report. 

Keep the report open as you will need to refer to it in the next procedure. 

Next, you will save the new calibration as a site that can be used by other projects in the 
same area. 

Step 5. Save the site calibration as a new site 
1. On the Calibration Setting tab, click the Save as Site button. 

The Save as Site pane displays. 

 

2. In the Name of site field, enter a name for the new site: Tutorial. Then click OK. 

You can now close the current project and start a new project using the newly 
created site. 

3. Select File > Close Project. 

The Save Changes dialog displays. If you saved the project to a new location or with 
a new name, you can click Yes. Otherwise, click No. 

4. In Spectra Precision Survey Office, select File > New Project.  

5. In the New Project dialog, select <Blank Template> and click OK.  
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6. After the new project opens, select Project > Change Coordinate System. 

 

7. Select the New System option and click the Next button. 

 

8. In the Select Coordinate System Type, dialog select the Calibrated Site option and 
click the Next button. 

 

9. In the Select Calibrated Site dialog, select Tutorial and click the Finish button.  
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10. To verify the site settings have been applied, select Project > Project Settings. 

11. In the Project Settings dialog, select Coordinate System > Site Calibration in the 
left navigation pane. 

 

12. Compare the horizontal and vertical parameters displayed the Project Settings 
dialog with the parameters contained in the Site Calibration report. 

13. Click OK to close the Project Settings dialog. 

You are done verifying the newly saved site.  

Note: To further verify the site, you could import the 2tank.jxl file into the new project 
and view the data in Google Earth. 

Since you will not be using the new Tutorial site after completing this tutorial, you can 
delete it. 

14. To delete the Tutorial site, do the following: 

a. Select Tools > Coordinate System Manager. 
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b. In the Coordinate System Manager window, select the Sites tab. 

 

c. Right-click the Tutorial site and select Delete in the context menu. 

d. In the Confirm Delete dialog, click OK. 

e. Select File > Exit to close the Coordinate System Manager window. 

15. On the Spectra Precision Survey Office menu bar, select File > Close Project. 

There is no need to save this project. You are done working with site calibrations. 
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