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About this tutorial 
In this tutorial, you will import two data files captured with a Trimble DiNi level into a 
project that already contains GNSS data. 

Note: If you need additional help at any time you are using the software, press F1 to 
display the online help. 

Step 1. Open the project 
For this tutorial, you will use the project file Importing Digital Level Data.vce. GNSS data 
has already been imported into the project, and GNSS baselines have been processed. 

1. On the Spectra Precision Survey Office menu bar, select File > Open Project. Or, 
click the Open Project icon  on the toolbar. 

2. In the Open File dialog, browse to C:\Spectra Precision 
Tutorials\SPSO\Projects\Importing Digital Level Data.vce and click Open. 

If you installed the tutorial to a location other than the default location shown here, 
browse to that location. 

The project opens in the Spectra Precision Survey Office window. 
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Note: This figure shows the Plan View with a white background. Your background 
may be black. If you want to change it to white, select Tools > Options and select 
Background color: White in the Options dialog. 

The project file is read-only. You can perform the tutorial steps without saving the project 
file. However, if you are interrupted while performing the tutorial, you can save it by 
selecting File > Save Project As and saving it to ..\My Documents\Spectra Precision 
Survey Office, which is the typical location for storing project files on your computer. 
Then, you can re-open the project to continue the tutorial at a later time. 

Before you import digital level data into your project, you will select a default standard 
error to use for the data. 

Note: You can change the default standard error for a project at any time. However, to 
apply the changes, you must open and close the Level Editor dialog as described later 
in this tutorial. 

Step 2. Select a default standard error 
In this step, you will select to use default standard errors in your project, and verify the 
default value to be used to calculate the standard error applied to observations in the 
Level Editor. 

1. Select Project > Project Settings. Or, click the Project Settings icon  on the 
toolbar. 

2. In the navigation (left) pane in the Project Settings dialog, select Default Standard 
Errors. 

3. In the Leveling section, select Project Settings in the Source for standard errors 
drop-down list. 

 

This ensures that the standard error value you specify in Project Settings (as 
described in the next two steps) is used to calculate the standard error applied to 
observations in the Level Editor. 



 Step 3. Import the first digital level data file  

Spectra Precision Survey Office Tutorial – Importing Digital Level Data 5 

Note: As an alternative, you could select to use a standard error value specified in 
the data file and displayed in an editable field in the Level Editor dialog during 
import. This would be helpful if, for example, you were importing level data from 
multiple DiNi instruments with differing accuracies and you wanted to edit the 
standard error for each during import. But, for this tutorial, you will use the Project 
Settings value. 

4. In the navigation pane in the Project Settings dialog, select Default Standard 
Errors > Leveling. 

5. In the Default standard error on 1 km of double leveling field, enter 0.7 mm. 

Ensure that the Default standard error for each station setup field contains the 
value 0.0 mm. If values are specified in both fields, the standard errors for leveling 
will use the combination of these two values to calculate the standard errors for the 
observations. 

 

6. Click OK. 

You are done changing project settings and are now ready to import digital level data into 
your project. 

Step 3. Import the first digital level data file 
For this tutorial, you will import two digital level data files. For the first data file, which 
contains multiple level runs, you will merge runs, rename and deselect points, and adjust 
the runs before importing. For the second data set, which contains a single level run, you 
will import the data without adjusting it. 

1. Select File > Import. Or, click the Import icon  on the toolbar. 
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The Import pane opens in the right side of the Spectra Precision Survey Office 
window. 

 

2. In the Import pane, click the Browse button . 

3. In the Browse For Folder dialog, browse to C:\Spectra Precision 
Tutorials\SPSO\Data\Importing Digital Level Data and click OK. 

The content of the Importing Digital Level Data folder displays in the Select File(s) 
list in the Import pane. 

4. In the Select File(s) list, select B412.DAT and click the Import button. 

The Level Editor dialog displays. 

 

This dialog allows you to review the level data you are importing and make changes 
as necessary. The sum of the BS and FS distances are displayed so you can verify 
observation distance balancing is met. 

The imported level data file includes data for six separate level runs that make up 
three double runs. In the sketch below you can see how the runs are connected. 
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Your first step is to merge level runs so the Level Editor can calculate misclosures. 

Step 4. Merge level runs 
In the B412.dat file, point B412 is the only point that has a control elevation entered (see 
the figure below). 

For the Level Editor to calculate misclosures, a run must begin and end on the same 
point, or begin and end on two control point elevations. These level runs either begin or 
end on a benchmark, or they begin or end on unknown points. In all of these cases, no 
misclosures are calculated for the runs. 

 

Note: It would be acceptable to import level data into the project without merging level 
runs or without misclosures. All the data would be combined to reflect the survey as it 
was ran. You could also perform a least-squares adjustment in the Level Editor without 
merging the runs. However, combining level runs provides a good quality check of the 
data and helps discover errors and blunders. 

For this tutorial, you will use the Level Editor to merge level runs. Note that for two level 
runs to be merged, the ending point of the first run must be the first point in the second 
run. 
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1. In the Level Editor dialog, click the Merge Runs button located in the lower-right 
corner of the dialog. 

The Merge Runs dialog displays. 

 

2. To merge runs, do the following: 

a. In the New run name field, enter 15. 

b. In the Start With Run Name list, select 1, which ends with point flange. 

c. In the Add This Run Name list, select 5, which starts with point flange. 

d. Click OK. 

The Run tabs in the Level Editor dialog show how runs 1 and 5 have been merged 
into a new run 15. 
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Note: In the Level Editor dialog, you can click the Reset button located in the lower-
right area of the dialog to undo any changes made to the file during the editing 
session. However, once you make changes and click OK, those changes are saved, 
including merged runs. If you re-open the Level Editor dialog for this file after import, 
clicking the Reset button will not undo the changes made in the previous editing 
session. If mistakes were made during the previous editing session, you can delete 
the file from the Project Explorer > Imported files area, then re-import the file. 

3. Repeat the merge procedure to merge runs as follows:  

a. Merge runs 6 and 2 into a new run 62. 

b. Merge runs 15 and 62 into a new run 1562. 

c. Merge runs 3 and 4 into a new run 34. 

A misclosure is displayed for each merged run, allowing you to determine if the runs 
have met their requirements. 

 

 

Step 5. Rename and deselect points 
In Run 1562 you can see points with a yellow dot next to the point ID. This indicates that 
the point is used in other runs within this file. 
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The Level Editor searches the file to find points that were named automatically by the 
Trimble DiNi level and the points that were uniquely named by the surveyor. This is why 
some points are checked to be created in Spectra Precision Survey Office and some 
are not. 

 

If one of these DiNi-named points or a point that is similar to the DiNi naming convention 
is actually meant to be created, you can select the box next to the Point ID to create the 
point in the project. 

In this file, some of the point IDs need to be renamed due to the number of characters in 
the point ID allowed by the DiNi. In these cases, the points need to be renamed to match 
points already in the project. 

1. Select the Run 1562 tab and change the point IDs for each of the following points by 
clicking in the Point ID field and typing the new name: 

 Change jeffcoaz to jeffco az mk. 

Since this point has other observations in this run, a message displays asking 
whether or not to rename all of the observations. Select Yes. 

 Change jeffco r to jeffco reset. 

Since this point is observed again only as the backsight for the next setup, no 
message displays asking whether or not to rename all of the observations. 

 Change A412 res to A 412 reset. 

In Run 34 there are several points selected to be created in the project that do not 
need to be created. You can de-select them, as explained in the next step. 

2. Select the Run 34 tab and deselect the following points in the Create column: 

 HYD1 

 thing 

 HYD2 

 HYD3 

You are now ready to adjust level runs and import the data. 
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Step 6. Adjust level runs and import the data 
Note that misclosures for Run 1562 and Run 34 have been calculated. 

 

 

You could import this data using the raw elevations, and then use the Adjust Network 
command in Spectra Precision Survey Office to adjust the errors in the data. But, for 
this tutorial you will be using the DiNi established points as vertical control points for a 
network adjustment, so you need to adjust the runs in the Level Editor. 

1. Click the Adjust Runs button located in the lower-right area of the dialog. 

The Adjust Runs dialog displays. By default, both runs are selected to be adjusted. 

 

2. Click OK.  
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A least-squares adjustment is performed on the data. The correction and adjusted 
elevation displays for each point in the Level Editor dialog. 

 

You can now use these adjusted elevations when you perform a network adjustment 
to adjust the other data in the project. 

3. In the Creation Options box in the lower area of the Level Editor dialog, select the 
Prevent further adjustment option. 

 

This will cause each point to be created with a Control quality elevation. Only the 
Control quality elevation will be imported; the observation will not. For the network 
adjustment, these points will be in the Fixed Coordinates list, eligible to be used as 
fixed points. 

If you had selected the Allow network adjustment option, each point would be 
created with Survey quality and the accumulated delta elevation observations 
between the points would be created. 

4. Click OK to import the adjusted level data into your-project. 

5. To view the newly imported digital level data in the Project Explorer.  

a. Select View > Project Explorer. 

b. In the Project Explorer, click the plus symbol preceding Imported Files. 
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c. Scroll down to B412.DAT, right-click the file name, and select Expand in the 
context menu. 

 

You are now ready to import the second digital level data file required for this project. 

Step 7. Import the second digital level data file 
For this step, you will import a level data file with only one level run. It is a loop starting on 
point sixtwo The surveyor assumed an elevation of 100.000 when he started the run. 
Point sixtwo was one of the control points established by the B412.DAT level data. 
Because the points in those runs were stored as control points, you can use those 
elevations to establish elevations in this run. The point must have an elevation with 
Control quality to be selectable here. 

In "Step 3. Import the first digital level data file," you imported data using the Import 
command. For this step, you are going to use a different method for importing data: drag-
and-drop. 

1. In Windows, select Start > (My) Computer and browse to C:\Spectra Precision 
Tutorials\SPSO\Data\Importing Digital Level Data. 

2. In the Digital Level Data folder, click and drag the SIXTWO.DAT file onto the Plan 
View in the Spectra Precision Survey Office window. 

The Level Editor dialog displays. 

 

3. In the Elevation Type field for point sixtwo, select Coordinate in the drop-down list 
and click off the field. 
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The Level Editor reads the elevation of point sixtwo from the project and enters it in 
the Adjusted Elevation field. 

 

This loop runs through several points in your project: sixtwo, hanna, and filter. 
However, there are several other points in the run that do not need to be created. 

4. In the Create column, deselect all points except for sixtwo, hanna, and filter. 

Since this is a loop level run, the Level Editor has calculated a misclosure of 
0.00550m. 

 

You could adjust this run to correct for this error as you did with the B412.DAT file. 
But instead, you will import the data without an adjustment. The data will be adjusted 
later as part of a network adjustment. 

5. Click OK to import the second data file into your project. 

The newly imported digital level data displays in the Project Explorer. 

 

You are done importing digital level data into your project. 

6. Select File > Close Project. 

The Save Changes dialog displays. If you saved the project to a new location or with 
a new name, you can click Yes. Otherwise, click No. 
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