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About this tutorial 
In this tutorial, you will process and edit feature codes that have been imported into your 
project. Then you will view feature data in the various project views, and export the 
features as a CAD drawing. 

Note: If you need additional help at any time you are using the software, press F1 to 
display the online help. 

Understanding feature code processing 
When a surveyor observes a feature in the field, he can make a record of it that includes 
the type of feature (for example, a tree), along with its location and any associated 
attributes (for example, the height of the tree and a photo). He does this by selecting from 
a library of predefined feature codes imported from a Feature Definition (.fxl) file, and 
supplying attribute values as required. The feature codes, along with any associated 
photos and attribute values, can then be imported into a Spectra Precision Survey Office 
project and processed using the same feature definitions.  

After feature codes have been processed, the software can display symbols and line 
work that represent the real world objects. Features can then be exported to other 
systems (for example, CAD or GIS) as necessary. 

There are three basic types of features: 

 Point feature - A point feature is used to identify a single feature, such as tree or 
utility pole. Each point feature is assigned to a point, which specifies its location. After 
a point feature code is processed in Spectra Precision Survey Office, the resulting 
feature is typically represented by a specific symbol displayed on top of the point in 
the various graphic views. You can view and edit attribute values assigned to a point 
feature by opening the Properties pane for the point to which it is assigned. 

 Line feature - A line feature is used to identify a line, such as a fence or curb. When 
points with line feature codes are processed in Spectra Precision Survey Office, a 
linestring with feature data is created. The feature linestring can be easily edited 
using the Edit Linestring command. If offset lines are specified for the line feature, 
additional linestrings are created. The line style used for the linestring is determined 
by the feature definition used to define the line feature. You can view and edit 
attribute values assigned to a linestring feature by opening the Properties pane for 
the linestring. 

 Polygon feature - A polygon feature is used to identify a feature with a polygonal 
shape, such as a concrete pad or retaining wall. When a polygon feature is 
processed in Spectra Precision Survey Office, it is converted to a polygon that can be 
easily edited using the Edit Polygon command. The border line style and fill used for 
the polygon is determined by the feature definition used to define the polygon 
feature. 

If a point, line, or polygon feature includes a photo or other media file attribute, a Media 
Folder icon  is displayed with the point, linestring, or polygon in the graphic views. You 
can view a media file by opening the appropriate Media Folder. 
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Step 1. Open the project 
For this tutorial, you will use the project file Processing Feature Codes.vce. The project 
includes data from a Cadastral survey of a city bus terminal. Integrated surveying 
methods were used to collect the field data.  

1. On the Spectra Precision Survey Office menu bar, select File > Open Project. Or, 
click the Open Project icon  on the toolbar. 

2. In the Open File dialog, browse to C:\Spectra Precision 
Tutorials\SPSO\Projects\Processing Feature Codes.vce and click Open. 

If you installed the tutorial to a location other than the default location shown here, 
browse to that location. 

The project opens in the Spectra Precision Survey Office window. 

 

Note: This figure shows the Plan View with a white background. Your background 
may be black. If you want to change it to white, select Tools > Options and select 
Background color: White in the Options dialog. 

The project file is read-only. You can perform the tutorial steps without saving the project 
file. However, if you are interrupted while performing the tutorial, you can save it by 
selecting File > Save Project As and saving it to ..\My Documents\Spectra Precision 
Survey Office, which is the typical location for storing project files on your computer. 
Then, you can re-open the project to continue the tutorial at a later time. 
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Step 2. Import the Feature Definition (.fxl) file 
Before you can process the feature codes imported into your project, you must import the 
same Feature Definition (.fxl) file that was used to assign codes in the field. There are 
three ways of doing this: 

 Use the Feature Code Processing section of the Project Settings dialog to import 
the Feature Definition (.fxl) file.  

 Use the Import pane to import the Feature Definition (.fxl) file. After import, the 
imported file is displayed in the Feature Code Processing section of the Project 
Settings dialog. 

 When you import a Job (.job) or JobXML (.jxl) file that specifies a Feature Definition 
(.fxl) file that is included in the same folder, the Feature Definition (.fxl) file is 
automatically imported into your project as well. After import, the imported file is 
displayed in the Feature Code Processing section of the Project Settings dialog. 

In this step, you will import the Feature Definition (.fxl) file created for this tutorial using 
the Project Settings dialog. 

1. Select Project > Project Settings. 

2. In the navigation (left) pane in the Project Settings dialog, select Feature Code 
Processing. 

 

3. Click the Browse button  located to the right of the Feature definition file field. 

4. In the Open  dialog, browse to C:\Spectra Precision 
Tutorials\SPSO\Data\GlobalFeaturesTutorial.fxl  and click Open. 

5. In the Project Settings dialog, click OK to close the Project Settings dialog.  

The feature definitions contained in GlobalFeaturesTutorial.fxl are imported into your 
project's Feature Definition Library to be used for feature processing. 

However, before processing, you will take a look at the unprocessed feature codes in 
your project. 
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Step 3. View unprocessed feature codes 
Before you process the feature codes in your project, you can view the codes and their 
assigned values, and make changes if necessary. 

1. Select View > Project Explorer. Or, click the Project Explorer icon  on the 
toolbar. 

The Project Explorer pane displays. 

2. In the Project Explorer pane, click the plus symbol next to the Points node. Then 
double-click point 700. 

 

The Properties pane displays on the right side of the window showing properties for 
point 700. The feature code assigned to the point displays in the Point Information 
section. 
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3. Click  in the Feature code field to view more information about the feature code in 
the Feature Code Editor dialog. 

 
This dialog allows you to remove a feature code, select a different feature code, add 
a feature code, and/or change attribute values. Note that the feature codes are 
defined in the GlobalFeaturesTutorial.fxl file.  

4. To view the photo assigned to point 700, select the photo attribute row and click the 
View File icon . 

The photo displays in your default photo viewing software. 
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5. When you are done viewing the Feature Code Editor, click Cancel to close the 
dialog. 

You are now ready to process the feature codes in your project. 

Step 4. Process feature codes 
You must process features codes to display their associated features correctly in graphic 
views and to export feature data. 

1. Select Survey > Process Feature Codes. Or, click the Process Feature Codes 
icon  on the toolbar. 

2. In the Process Feature Codes pane, select the checkbox for rtd topo.jxl and click 
the Process Source(s) button. 

 

After processing is complete, the Feature Codes Processing dialog displays asking 
if you want to view the Feature Code Processing Report. 

3. In the Feature Codes Processing dialog, click Yes. 

The Feature Code Processing Report displays on a new tab in the Spectra 
Precision Survey Office window. 

4. Scroll to the "Unknown Feature Codes" section. 

Note that there are four points whose feature codes are unknown. This means that 
there is no corresponding feature code contained in the project's Feature Definition 
Library to process the codes. In this case, the codes were incorrectly entered in the 
field.  

Next, you will fix the unknown feature codes before reprocessing. 

Step 5. Change feature codes 
In this procedure, you will assign the correct feature code to each of the four points listed 
in the "Unknown Feature Codes" section of the Feature Code Processing Report. But, 
because codes are read-only after features have been processed in your project, you 
must remove the processing results before you can make changes to the codes.  

1. To remove feature processing results: 

a. Select Survey > Process Feature Codes. Or, click the Process Feature Codes 
icon  on the toolbar. 
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b. In the Process Feature Codes pane, select the checkbox for rtd topo.jxl, and 
click the Remove Processing button. 

 

By default, the Feature Code Processing Report opens in Print Preview to better 
facilitate scrolling long reports. However, to enable the links in the report, you must 
first change the layout to the Normal view. 

2. In the toolbar at the top of the Feature Code Processing Report tab, click the Print 
Layout button  to toggle to Normal view. 

3. In the "Unknown Feature Codes" section of the Feature Code Processing Report, 
click point 727. 

The properties for point 727 are displayed in the Properties pane. 

 

The yellow icon  at the right in the Feature code field indicates the point has an 
unknown feature code. You can enter a new code directly in the field if you know it 
and you do not need to specify any attributes. Otherwise, you can click the  button 
to open the Feature Code Editor dialog to make the changes. For this tutorial, you 
will use both methods. 

4. Click the  button in the Feature code field. 
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The Feature Code Editor dialog displays. 

 

5. In the Feature code field, select rd and press the Delete key to remove the code. 

6. In the GlobalFeaturesTutorial.fxl list, select RB (RoadBarrier) and click the Add 
Code button. 

The code is added to the Feature code field. 

 

7. Click OK. 

The newly assigned code displays in the Feature code field in the Properties pane 
for point 727. 

 

8. Change codes for the other points displayed in the "Unknown Feature Codes" section 
of the Feature Code Processing Report. Just click each point in the report to display 
its properties in the Properties pane. 
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a. For point 728, change rd end to RB END. 

For this change, click the  button to open the Feature Code Editor dialog. 
Delete rd end from the Feature code field. Then select RB (RoadBarrier) in the 
GlobalFeaturesTutorial.fxl list and click the Add Code button. The code RB 
represents a line feature and should include the END (EndLine) line control code. 
Click the Category filter icon  and select Line Control Code to display only 
line control codes in the list. 

 

Select END in the list, and click the Add Code button.  

 

Then click OK to see the change in the Properties pane for point 728. 

 

b. For point 780, change cb 1x2m to CBI 1x2m. 

For this edit, type the change directly in the Feature code field. Note that the 
italicized text 1x2m is simply a free-form description for the code preceding it. 

 

c. For point 781, change cb inv to CBI INV. 
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Again, type the change directly in the Feature code field. 

 

You are now ready to reprocess the feature codes with the changes you made. 

Step 6. Reprocess feature codes 
1. Select Survey > Process Feature Codes. Or, click the Process Feature Codes 

icon  on the toolbar. 

2. In the Process Feature Codes pane, select the checkbox for rtd topo.jxl and click 
the Process Source(s) button. 

After processing is complete, the Feature Codes Processing dialog displays asking 
if you want to view the Feature Code Processing Report. 

3. In the Feature Codes Processing dialog, click Yes. 

A new Feature Code Processing Report displays on a new tab in the Spectra 
Precision Survey Office window. Note that there are no longer any unknown feature 
codes listed in the report. 

You can now view the processed features. 
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Step 7. View processed features 
1. Select the Plan View tab and use your mouse wheel to zoom in to view the 

processed feature data, as shown below.  

 

To better view the features, you can choose to hide unnecessary data in the Plan 
View. 

2. Select View > View Filter Manager. 

The View Filter Manager pane displays. 

 

3. In the Raw Data list: 

 Deselect RTK Vector. 

 Deselect Total Station. 
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Point feature symbols and feature linestrings are more clearly visible in the Plan 
View. 

 

To view information about a feature, including any attribute values, you can select the 
point or linestring to which the feature is assigned.  

4. In the Plan View, click the red symbol on point 700 and select Point: 700 in the 
context menu. 

The Properties pane for point 700 displays. In the lower portion of the pane, the 
Feature section displays the processed feature name and attribute values assigned 
to the point feature. 

 

You can select a different feature or change any attribute values using these fields. If 
you select a different feature for the point and then reprocess the feature codes in 
your project, the new feature you assigned to the point is kept with the point, while 
the original feature code is used to create a "secondary" feature for the point, which 
you can select in the Plan View. 

Although you can select a different feature for a point, you cannot edit the point's 
feature code after you have processed feature codes in your project. If you needed to 
change the code, you would first have to remove the feature processing results as 
described earlier in this tutorial. 
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If a feature includes a media attribute, such as a photo, a Media Folder icon  is 
displayed next to the point, as shown here.  

 

Note: A Media Folder is attached to any point or line to which a media file is 
assigned, whether it was assigned to the point as a feature attribute or assigned 
some other way. If a media file (for example, a photo) is assigned to a point as a 
feature attribute and additional media files are assigned to the point as well, you can 
select to use one of the other media files as the feature attribute by selecting it in the 
media (for example, Photo) drop-down list in the Feature section of the Properties 
pane. 

5. In the Plan View, click the Media Folder icon for point 700 and, if necessary, select 
Media Folder: 700 in the context menu. 

The Properties pane for the Media Folder is displayed showing the media file 
assigned to the point and information associated with it. You can click the View 
button  located to the right of the media file path to view the image in your default 
photo viewing software. 

6. In the Plan View, click the line running through point 700 and, if necessary, select 
Linestring: GutterLeft in the context menu. 

This is a linestring created from line feature codes during processing. The Properties 
pane for the linestring displays showing the feature name and any feature attributes.  

You can also view the features in your project in 3D. But before you do, you will apply 
additional filters to your view to make the features easier to see. 

7. In the View Filter Manager pane: 

 In the Raw Data list, deselect Media Folder. 

 In the Layers list, deselect Points.  

 On the Point tab, deselect Show point labels. 



 Step 7. View processed features  

Spectra Precision Survey Office Tutorial – Processing Feature Codes 16 

 On the Point tab, select Show feature symbol only. 

 

8. Select View > New 3D View. Or, click the New 3D View icon  on the toolbar. Then 
use your mouse wheel to zoom in as shown here. 

 

9. Select View > 3D View Settings. 

The 3D View Settings pane displays. You can use the controls in this pane to 
change the 3D view of the features. 

a. In the Vertical angle field, enter 54°00'00". 
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b. In the Azimuth field, enter 25°00'00". 

 
Note that by setting the Vertical Exaggeration factor to approximately 5 (experiment 
by sliding the control right and left), you can spot the elevation bust on a curb. 

 

10. To view the feature data in Google Earth, do the following: 

a. Select View > Google Earth. 

b. In the Google Earth pane, click the Options button and select Select All. 

 

c. Click the Apply button. 
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Points, feature lines, and camera icons are displayed in Google Earth. You can click 
any camera icon to display the associated image. 

 

Next, you will export the processed feature data as a CAD drawing file. 

Step 8. Export as a CAD drawing 

1. Select File > Export. Or, click the Export icon  in the toolbar. 

2. In the Export pane, select the CAD tab. 

 

3. On the CAD tab, select DWG exporter in the list at the top of the tab. 

4. In the Data section, click the Options button and select Select All. 

5. Click the Export button to create the CAD drawing (.dwg) file and save it to your 
project folder. 

You are done working with feature codes. 

6. Select File > Close Project. 

The Save Changes dialog displays. If you saved the project to a new location or with 
a new name, you can click Yes. Otherwise, click No. 
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