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About this tutorial 
In this tutorial, you will process baselines from GNSS data that has already been 
imported into the project. 

Notes: 

 For this tutorial, you will be processing baselines for data that includes both L1 and 
L2 signals. You can perform the procedures described in the tutorial while running 
Spectra Precision Survey Office software with the Basic product license; however, 
only the L1 data will be processed. The Complete product license is required to 
process baselines for L1 and L2 data. To verify the product license for your 
installation, select Help > About Spectra Precision Survey Office and click the 
License button. Licensed features are displayed in the Features list. 

 If you need additional help at any time you are using the software, press F1 to display 
the online help. 

 

Step 1. Open the project 
For this tutorial, you will use the project file Processing GNSS Baselines.vce. GNSS data 
has already been imported into the project, but baselines have not yet been processed. 

1. On the Spectra Precision Survey Office menu bar, select File > Open Project. Or, 
click the Open Project icon  on the toolbar. 

2. In the Open File dialog, browse to C:\Spectra Precision 
Tutorials\SPSO\Projects\Processing GNSS Baselines.vce and click Open. 

If you installed the tutorial to a location other than the default location shown here, 
browse to that location. 
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The project opens in the Spectra Precision Survey Office window. 

 

Note: This figure shows the Plan View with a white background. Your background 
may be black. If you want to change it to white, select Tools > Options and select 
Background color: White in the Options dialog. 

The project file is read-only. You can perform the tutorial steps without saving the project 
file. However, if you are interrupted while performing the tutorial, you can save it by 
selecting File > Save Project As and saving it to ..\My Documents\Spectra Precision 
Survey Office, which is the typical location for storing project files on your computer. 
Then, you can re-open the project to continue the tutorial at a later time. 

Before you process baselines for the project, you should check the baseline processing 
settings to ensure they are appropriate for your project. 

Step 2. Specify the processing interval 
Before processing baselines for your project, you can choose the interval (in seconds) at 
which you want to select field data to process, or you can choose to use the interval 
specified in the data file. The shorter the interval, the more data is processed, resulting in 
a longer processing time and higher precision. If you choose an interval that is shorter 
than the interval at which the data was collected, the interval at which the data was 
collected is used.  

Ideally, you would choose to use the interval specified in the data file to ensure you are 
using the shortest intervals possible. However, for long occupation times with intervals 
(epochs) of 1 second or less, the processing time could be very long. In this case, you 
might choose to use a longer interval to shorten the processing time. For this tutorial, you 
will select a processing interval of 5 seconds to keep the processing time as short as 
possible.  
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1. Select Project > Project Settings. Or, click the Project Settings icon  on the 
toolbar. 

2. In the navigation (left) pane in the Project Settings dialog, select Baseline 
Processing > Processing. 

3. In the Processing interval drop-down list, select 5 (seconds). 

 

Note that you can select other options that affect baseline processing. Helpful tips are 
displayed in the lower portion of the dialog, or you can press F1 at any time for 
additional online help. For this tutorial, you should not make any other changes. 

4. Click OK to close the Project Settings dialog. 

You are now ready to process baselines. 

Step 3. Process baselines 

1. Select Survey > Process Baselines. Or, click the Process Baselines icon  on 
the toolbar. 

Note: If no baselines are selected in the various views when you select the Process 
Baselines command (as in this case), all baselines in your project are processed. If 
any baselines are selected, only those baselines are processed. 
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The Process Baselines dialog displays showing the progress of the process. 

 

When processing is complete, the processed baselines are listed in the table. You 
can sort the baselines as necessary by clicking any of the column headings. For 
example, you can sort baselines to verify that desired accuracy has been met by 
clicking the Horiz. Precision and Vert. Precision column headings. 

To see more information about any specific baseline, select the row and click the 
Report button to display the Baseline Processing Report in HTML format in your 
browser window. 

Note: When you select to open a Baseline Processing Report from anywhere else in 
Spectra Precision Survey Office, the report opens on a viewing tab in RDLC 
(Report Definition Language Client-side) format, which can then be saved in PDF 
format. 

2. In the Process Baselines dialog, click the Save button to save the processed 
baselines. 

The project is re-computed with the newly created baselines. 

You can view the Point Derivation Report for any point to see the resultant 
coordinates.  

3. Select the point fsi in the Plan View. Then right-click and select Point Derivation 
Report in the context menu. 

The Point Derivation Report displays in your browser window. 

If an error flag had displayed for a baseline in the Process Baselines dialog, you would 
need to ensure all the information about that baseline is correct (for example, antenna 
type, antenna height, and point name). In some cases, reprocessing the baseline by itself 
will clear a flag by using a different coordinate seeding. Depending on the underlying 
problem, there are a number of actions you could take, including possibly editing the 
associated session. 

In the next step, you will edit a session and reprocess a baseline as if an error flag had 
been displayed in the Process Baselines dialog, even though one did not. This will help 
familiarize you with the Session Editor. 
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Step 4. Edit a session and reprocess a baseline 
The Session Editor allows you to visually analyze the quality of the raw satellite data 
collected for the selected session. Gaps in satellite data can indicate satellite signal cycle 
slips, invalid range errors, and other signal loss problems. To improve the quality of a 
processed baseline, you can use the Session Editor to disable unhealthy satellites, 
mask bad sections of satellite data, and adjust occupation times. 

In this step, you will edit a session associated with a baseline to correct for gaps in the 
satellite signal. Then you will reprocess the baseline.  

Note: This procedure is intended to familiarize you with the Session Editor. If this were 
a real project, there would be no need to reprocess the specified baseline since it is 
within the acceptance criteria specified for the project. 

1. Click on the Plan View and use your mouse wheel to zoom in so that you can 
distinguish the baseline between the points fsi and 3. Then, click on the baseline and 
select Baseline fsi --- 3 (B15) in the context menu. 

 

2. Right-click anywhere on the Plan View and select Session Editor in the context 
menu. 
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The Session Editor dialog displays. 

 
Satellites that provided data for the session include blue and/or green lines on the 
timeline. Each blue line represents data collected for the first point in the baseline 
(fsi). Each green line represents data collected for the second point in the baseline 
(3). 

Each satellite is represented by a letter and number in the left column: 

 G = GPS satellite 

 R = GLONASS satellite 

 E = Galileo satellite  

Note that the signal for the satellite G7 ends early in the session. The satellite 
probably moved beyond the horizon at that point. Although it is not necessary in this 
case, you will disable the satellite G7 data for this tutorial. 

3. In the left column, click G7. 

The entire row is shaded to show the satellite data will be disabled (that is, the data 
will not be used for processing) when you click OK. 

Next, you will disable part of the R17 and R18 satellite data in which there are cycles 
slips as indicated by breaks in the blue and green lines. 

4. In the R17 row, click in front of the first slip and drag your cursor to the end of the 
row. 

 

5. In the R18 row, click and drag across the cycle slips in the earlier part of the session. 
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In this procedure you are disabling satellites data only for the selected baseline. If 
you want to disable a satellite for all baselines in your project, select Project > 
Project Settings. Then select Baseline Processing > Satellites and remove the 
checkmark from the satellite you want to disable. This is also where you could raise 
or lower the elevation mask to try and improve baseline results. 

6. Click OK to close the Session Editor dialog. 

You are now ready to reprocess the baseline. 

7. With Baseline fsi --- 3 (B15) still selected, select Survey > Process Baselines. Or, 
click the Process Baselines icon  on the toolbar. 

The Process Baselines dialog displays and the selected baseline is reprocessed. 

8. When processing is complete, click the Save button. 

You are done processing GNSS baselines. In the next step, you will identify and disable 
dependent baselines in your project. 

Step 5. Identify and disable dependent baselines 
If you plan to use only independent baselines in the network adjustment, you can use the 
Time-Based View to identify dependent baselines and disable them. 

Note: Disabling a baseline deletes the associated vector. If you want to retain a vector 
you must disable it, not the baseline. Instructions for disabling vectors are not included in 
this tutorial. 

Following is a diagram of the survey data used in this project. 

        

The circled numbers indicate the session in which each baseline was measured. In the 
session 1, points fsi, 5, frey, and hanna were occupied. The total number of baselines 
that can be observed during a session is equal to  

 
where n equals the number of receivers used during the session. 

For example, if four receivers were used in a session, six baselines can be observed (4 
times 3, divided by 2). 

The number of independent baselines for a given session is equal to . 

For this project, three independent baselines were measured for each session. In the five 
sessions observed, 30 baselines were measured, but only 15 are independent.  
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Using the CORS station, you must add another receiver into the count. This increases 
the total baselines per session to 10 and the number of independent baselines to four. 
There are 50 total baselines and 20 independent baselines for all sessions. 

To disable dependent baselines, follow these steps: 

1. Select View > New Time-Based View. Or, click the New Time-Based View icon  
on the toolbar. 

The Time-Based View displays. The following figure identifies sessions 1 and 2. 
(The other sessions are not shown in this figure.) 

 

You can use your mouse to navigate the Time-Based View as follows: 

 Place you cursor over the sessions, press your mouse wheel, and move the 
mouse back and forth to pan the view horizontally. 

 Use the mouse wheel to scroll the view vertically up and down. 

 Place you cursor over the sessions, press and hold the left mouse button, and 
move the mouse up to zoom in, or move it down to zoom out. 

 Right-click to see other zoom options. 



 Step 5. Identify and disable dependent baselines  

Spectra Precision Survey Office Tutorial – Processing GNSS Baselines 11 

2. To ensure you are working with the correct session, use Shift + click in the left 
column to select all of the baselines in session 1. 

 

3. Using Ctrl + click, deselect the independent baselines in session 1. These are the 
baselines you do not want to disable. 

 P041 --- hanna  
Note that since you are using the observation from P041 to the points on the 
exterior of your network, you must deselect this baseline. 

 5 --- fsi  

 hanna --- frey  
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 5 --- frey  

 

4. Right-click on any of the remaining selected baselines in session 1 and select 
Disable Baselines in the context menu. 

A message is displayed alerting you that associated vectors will be deleted.  

5. In the Delete Vectors message dialog, click Yes. 

6. In the Time-Based View, the disabled baselines are displayed with a dark gray bar. 

 

7. Repeat this procedure for sessions 2 through 5, ensuring all dependent baselines are 
disabled. 
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The independent baselines for each session are as follows. These baselines should 
not be selected to be disabled. All other baselines should be selected to be 
disabled. 

Session 2: 

 3 --- filter  

 P041 --- sixtwo  

 3 --- sixtwo  

 sixtwo --- hanna  

Session 3: 

 hanna --- filter 

 filter --- 5 

 filter --- frey  

 P041 --- frey  

Session 4: 

 P041 --- fsi  

 fsi --- 3  

 3 --- sixtwo  

 3 --- 5  

Session 5: 

 P041 --- sixtwo  

 frey --- hanna  

 sixtwo --- hanna  

 frey --- 5  

Now that you have disabled baselines, you must recompute the project. 

8. Select Project > Compute Project. Or, press the F4 key. 

Note that flags now display on points frey, filter, and 5 in the Plan View. 

 

9. Select View > Flags Pane. 



 Step 5. Identify and disable dependent baselines  

Spectra Precision Survey Office Tutorial – Processing GNSS Baselines 14 

In the Flags Pane, you can see that the flagged points exceed the horizontal point 
tolerance that has been specified for the project. 

 

For this tutorial, you will change the tolerance to be less restrictive so the flags no 
longer display.  

10. To change the horizontal tolerance for points in the project, do the following: 

a. Select Project > Project Settings. Or, click the Project Settings icon  on the 
toolbar. 

b. In the Project Settings dialog, select Computations > Point Tolerances in the 
navigation pane located on the left side of the dialog. 

c. In the Survey Quality section, change the Horizontal tolerance (Survey) field 
to 0.028 m.  

d. Click OK. 

The flags no longer display in the Plan View or Flags Pane. 

11. To view only the enabled observations and baselines (for postprocessing) in the Plan 
View, do the following: 

a. Select Plan View. 

b. Select View > View Filter Manager. 

The View Filter Manager pane displays. 

 

c. Select the Observations tab in the bottom area of the pane, and select the 
Enabled observations only option. 

d. Select the GNSS Data Types tab in the bottom area of the pane, and select the 
Enabled baselines only (for postprocessing) option. 

e. Click on the Plan View and use your mouse wheel to zoom in. Press the mouse 
wheel and move the mouse to center the points as shown in the second figure. 
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Plan View before filtering the view: 

 

Plan View after filtering the view: 

 

You are done disabling dependent baselines in your project. 

12. Select File > Close Project. 

The Save Changes dialog displays. If you saved the project to a new location or with 
a new name, you can click Yes. Otherwise, click No. 
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