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About this tutorial 
In this tutorial, you will view spreadsheets, create a selection set, and work with COGO 
controls. 

Note: If you need additional help at any time you are using the software, press F1 to 
display the online help. 

Step 1. Open the project 
For this tutorial, you will use the project file Using Spreadsheets.vce. GNSS, total station, 
and level data has already been imported into the project, and GNSS baselines have 
been processed. 

1. On the Spectra Precision Survey Office menu bar, select File > Open Project. Or, 
click the Open Project icon  on the toolbar. 

2. In the Open File dialog, browse to C:\Spectra Precision\Tutorials\SPSO\Projects\ 
Using Spreadsheets.vce and click Open. 

If you installed the tutorial to a location other than the default location shown here, 
browse to that location. 

The project opens in the Spectra Precision Survey Office window. 

 

Note: This figure shows the Plan View with a white background. Your background 
may be black. If you want to change it to white, select Tools > Options and select 
Background color: White in the Options dialog. 
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The project file is read-only. You can perform the tutorial steps without saving the project 
file. However, if you are interrupted while performing the tutorial, you can save it by 
selecting File > Save Project As and saving it to ..\My Documents\Spectra Precision 
Survey Office, which is the typical location for storing project files on your computer. 
Then, you can re-open the project to continue the tutorial at a later time. 

You are now ready to explore some of Spectra Precision Survey Office’s features. 

Step 2. View spreadsheets 
In this step, you will view two spreadsheets available in Spectra Precision Survey 
Office: 

 Occupation Spreadsheet 

 Point Spreadsheet 

You can customize what is displayed in spreadsheets and how it is displayed, as shown 
in the following steps.  

1. Select Project > Project Settings. Or, click the Project Settings icon  on the 
toolbar. 

2. In the navigation (left) pane in the Project Settings dialog, select View > Points 
Spreadsheet. 

A list of the names of columns available for the Points spreadsheet display in the 
table. Each column name is followed by an indicator of whether the column should be 
included in the spreadsheet. 

 

You can click on any of the Show/Hide indicators to change the selection. 

In the navigation (left) pane in the Project Settings dialog, you can select other 
spreadsheets in the View menu to view and change the Show/Hide column settings 
for them as well. For this tutorial, there is no need to make changes. 

3. Click Cancel to close the Project Settings dialog. 

Next you will see how to customize a spreadsheet by sorting the rows in it. 
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4. Select View > New Points Spreadsheet. Or, click the New Points Spreadsheet 
icon  on the toolbar. 

The Point Spreadsheet displays. 

 

You can sort the rows in the spreadsheet based on the column heading you select. 
By default, the rows are sorted in ascending alphabetical order based on the Point 
ID. 

5. Click the Elevation column heading to sort the rows based on the ascending and 
descending elevation of the points. 

Note that the Sort icon  indicates whether the sort is in ascending (the arrow points 
up) or descending (the arrow points down) order. 

You can filter the displayed rows by clicking the filter icon  for a column and 
selecting the appropriate filter. The default filter is All. 

6. Click the Feature Code filter icon  and select NonBlanks in the context menu. 

 

Only points with feature codes assigned are displayed in the spreadsheet. 

You can further customize your spreadsheet as follows: 

 Resize the width of any column by placing the cursor on the column border in the 
heading row and dragging it left or right. 

 Move a column to a new location using "drag-and-drop." 

 Move the spreadsheet tab to a new location. Simply click on the tab label and 
drag it downward off the tab bar before releasing. Then select a location option in 
the context menu. 

Try selecting New Vertical Tab Group to display the tab vertically in the window. 

Use the same procedure to move the tab back. 
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Any content displayed in blue in the spreadsheet can be edited. For example, you 
can type in a new Point ID, or you can edit a Feature Code directly in the column or 
by clicking  to display the Feature Code Editor dialog. 

You can copy rows from a spreadsheet into a Microsoft Excel spreadsheet. Just 
select the rows you want to copy, press Ctrl+C to copy, select a cell in the Excel 
spreadsheet, and press Ctrl+V to paste. Although the header row cannot be 
selected, it is always copied and pasted into the spreadsheet along with the rows you 
select. 

You can display the Properties pane for any point by selecting the row, right-clicking, 
and selecting Properties in the context menu. 

Custom filters allow you to select the criteria for filtering data displayed in a 
spreadsheet. In the following example, you will select to view only the points that did 
not use the R8 GNSS/SPS88x Internal antenna type. 

7. Select View > New Occupation Spreadsheet. Or, click the New Occupation 
Spreadsheet icon  on the toolbar. 

The Occupation Spreadsheet displays. 

 

8. Click the Ant. Type filter icon  and select Custom in the context menu. 

The Enter filter criteria for Ant. Type dialog displays. 

 

9. In the Operator drop-down list, select Does not equal to. 

10. In the Operand drop-down list, select R8 GNSS/SPS88x Internal. Then click OK. 
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The spreadsheet refreshes based on your custom filter. Only points that did not use 
the R8 GNSS/SPS88x Internal antenna type display. 

 
You are done looking at spreadsheets. Next, you will take a look at how to create and 
use selection sets. 

Step 3. Create a selection set 
If you need to select the same objects over and over, it can be frustrating to manually 
make your selections and it is easy to make mistakes. Instead, you can use the 
Selection Explorer to create reusable selection sets. 

1. Click the Plan View. 

2. Use the Zoom In toolbar icon  to enlarge the view as shown here. Or, click on the 
Plan View and use your mouse wheel to zoom in. Press the mouse wheel and move 
the mouse to center the points. 

 

3. Select View > Selection Explorer. Or, click the Selection Explorer icon  on the 
toolbar. 
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The Selection Explorer pane displays. 

 

The Selection Explorer contains two lists: 

 The Selection Sets list in the top half of the pane. 

 The object list in the bottom half of the pane, which shows the objects you 
selected in the Plan View or that are contained in the selected selection set(s). 

4. In the Plan View, use your cursor to draw a selection box around the group of 
objects you want to include in your selection set, as shown here. 
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Your selections display in the Selection Explorer in the <Selection Snapshot> 
objects list. 

 

5. On the Selection Explorer toolbar, click the Save the selection list as icon . 

6. In the Save <Selection Snapshot> As dialog, enter a name for your selection set: 
YourName Selection. Then click OK. 

Your new selection set is added to the Selection Sets list. To view the objects 
contained in your selection set, simply select the set in the Selection Sets list. 

 



 Step 4. Work with COGO controls  

Spectra Precision Survey Office Tutorial – Using Spreadsheets, Selection Sets, and COGO 
Controls 10 

You can view properties for any object in the selection set by selecting it in the list, 
right-clicking, and selecting Properties in the context menu. To select multiple 
objects, use Ctrl + click or Shift + click. Selecting multiple objects can be 
particularly useful if you want to specify a property (for example, a feature code) for 
all of them at the same time. 

To select the objects in multiple selection sets, press the Ctrl key and make your 
selections in the Selection Sets list. 

You can use the other icons on the Selection Explorer toolbar to view properties for 
selected objects, remove selection sets, and add or remove objects in selection sets. 
For instructions, see the online Help. 

7. Close the Selection Explorer pane. 

You are done working with selection sets. Next, you will take a look at some useful 
COGO controls. 

Step 4. Work with COGO controls 
COGO (COordinate GeOmetry) controls are the boxes in various commands that help 
you calculate angles, bearings, coordinates, distances, elevations, and offsets in your 
project. They enable you to enter data in a variety of ways, including: 

 Typing values and point IDs in the box 

 Picking points in graphic views 

 Right-clicking in graphic views and selecting additional snap and COGO options from 
the context menu 

COGO controls provide this flexibility so that you have many ways in which you can enter 
data within a single command, rather than forcing you to work through multiple 
commands. 

COGO snap commands use geometric calculations to help you specify coordinates more 
easily and accurately. Snap commands can calculate a snap point by using existing 
geometry or by using parameters that you enter. Snap commands are available any time 
you are required to enter a coordinate. Simply right-click to see the options. 

In the following procedure, you will create four new points in your project (1, 2, 6, and 7) 
using the various COGO controls and snap commands available in Spectra Precision 
Survey Office. However, before you create new points, you should verify that snap mode 
options are set correctly. 

1. Click the Snap button on the status bar in the bottom of the Spectra Precision 
Survey Office window. 
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The Running Snap Mode Options dialog displays. 

 

This dialog allows you to specify snap mode options. The description for each option 
is displayed in the dialog. 

In this procedure you will be using snap commands to select points. To ensure you 
are selecting a point and not a coordinate near a point, you will deselect the Free 
mode. However, because this selection is a system setting and is not project-specific, 
you will reselect Free when you are done with this procedure. 

2. In the Running Snap Mode Options dialog, do the following: 

a. Verify the Point mode option is selected. 

b. Deselect the Free mode option. 

c. Click OK. 

3. Create point 1 as follows: 

a. Select Point > Create Point. 

The Create Point pane displays. 

 

b. Ensure the Point ID field displays 1, the Feature code field is blank, and the 
Coordinate type field is displays Grid. 

c. Right-click in the Northing field. 

d. In the context menu, select Bearing Distance Snap. 
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The Bearing Distance Snap pane displays. These controls enable you to 
calculate a point based on a beginning point, a bearing, and a distance. The zero 
(0) bearing is north; bearings use grid azimuths measured clockwise. 

 

e. Click in the Reference Point field, then click on point 5 in the Plan View. 

The coordinate for point 5 displays in the field. As an alternative, you could just 
type 5 in the field. 

f. In the Bearing field, enter S37 44 56E (or Azimuth field = 142 15 04). 

g. In the Distance field, enter 290.91sft. Then click OK. 

Note that the value specifies the distance unit sft. This is required if a value you 
want to enter uses a distance unit that is different than the unit specified in the 
Project Settings dialog. 

The coordinates for the new point 1 display in the Create Point pane. 

 

h. Click the Add button. 
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The new point 1 displays in the Plan View. The Create Point pane has been 
cleared so you can create another new point. 

 

4. Create point 2 as follows: 

a. In the Create Point pane, ensure the Point ID field displays 2. 

b. Right-click in the Northing field. 

c. In the context menu, select Bearing Distance Snap. 

The Bearing Distance Snap pane displays. 

 

d. In the Reference Point field, enter 3. 

e. In the Bearing field, enter N18 05 08E. 

f. In the Distance field, enter 322.91sft. Then click OK. 

The coordinates for the new point 2 display in the Create Point pane. 

g. Click the Add button. 
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The new point 2 is displayed in the Plan View. 

 

You are now ready to create a new point 6, which will be located midway between 
points 1 and 2. 

5. Create point 6 as follows: 

a. In the Create Point pane, enter 6 in the Point ID field. 

b. Right-click in the Northing field. 

c. In the context menu, select Middle of Point to Point Snap. 

The Middle of Point to Point Snap pane displays. These controls allow you to 
calculate a location midway between two points. 

 

d. In the From point field, enter 1. 

e. In the To point field, enter 2. Then click OK. 

The coordinates for the new point 6 display in the Create Point pane. 

f. Click the Add button. 
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The new point 6 is displayed in the Plan View. 

 

You are now ready to create a new point 7. 

6. Create point 7 as follows: 

a. In the Create Point pane, ensure 7 displays in the Point ID field. 

b. Right-click in the Northing field. 

c. In the context menu, select Bearing Bearing Snap. 

The Bearing Bearing Snap pane displays. These controls allow you to calculate 
the intersection of two bearings defined by a first point and second point. 

 

d. In the Reference point 1 field, enter 5. 

e. Right-click in the Bearing 1 field. 

f. In the context menu, select Bearing + Angle Snap. 
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The Bearing + Angle Snap pane displays. These controls allow you to calculate 
a bearing by adding an angle to a given bearing. 

 

g. Right-click in the Bearing  field. 

h. In the context menu, select Point to Point Bearing Snap. 

The Point to Point Bearing Snap pane displays. These controls allow you to 
compute the bearing from one point to another point. 

 

i. In the Reference point 1 field, enter 5 

j. In the Reference point 2 field, enter fsi. Then click OK. 

The Bearing + Angle Snap pane displays showing the new Bearing 1. 

 

k. In the Angle field, enter 5 (for 5 degrees). Then click OK. 
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The Bearing Bearing Snap pane displays. 

 

l. In the Reference point 2 field, enter 3. 

m. Right-click in the Bearing 2 field. 

n. In the context menu, select Point to Point Bearing Snap. 

The Point to Point Bearing Snap pane displays. 

 

o. In the Reference point 1 field, enter 3. 

p. In the Reference point 2 field, enter 6. Then click OK. 
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The Bearing Bearing Snap pane displays showing the new Bearing 2. 

 

q. Click OK. 

The coordinates for the new point 7 display in the Create Point pane. 

 

r. Click the Add button. 
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The new point 7 displays in the Plan View. 

 

You can now reselect the Free snap mode option in case you need it turned on for 
other projects. 

7. Reselect the Free snap mode option as follows: 

a. Click the Snap button on the status bar in the bottom of the Spectra Precision 
Survey Office window. 

b. In the Running Snap Mode Options dialog, select Free. 

c. Click OK. 

You are done working with COGO controls. Feel free at this time to continue 
exploring the Spectra Precision Survey Office software. Press F1 at any time to 
view the associated online Help. 

8. When you are done exploring, select File > Close Project . 

The Save Changes dialog displays. If you saved the project to a new location or with 
a new name, you can click Yes. Otherwise, click No. 
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